{"answers":{"affected":"2 open source packages ship an affected version, including @simple-git/argv-parser.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102829 exists.","fix":"Upgrade @simple-git/argv-parser to 2.0.1 or later.","what":"CVE-2026-102829 is a critical command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102829 and fix it if it is affected.\n\nWhat it is: CVE-2026-102829 is a critical command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102829 exists.\n\nAffected packages and fixed versions:\n- @simple-git/argv-parser (npm): affected all versions; fixed in 2.0.1\n- @simple-git/argv-parser (npm): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102829/ (Markdown: https://insights.sbomify.com/CVE-2026-102829/index.md)","id":"CVE-2026-102829","markdown":"https://insights.sbomify.com/CVE-2026-102829/index.md","name":"CVE-2026-102829","record":{"aliases":["CLEANSTART-2026-ES51269","CLEANSTART-2026-IX68198","CLSA-2026-1792595414","ECHO-bb3c-f0fd-74d5","GHSA-v5rq-49vh-5v5c","MINI-5cqr-37cc-7rc6","MINI-hjcf-rwp7-qg9r","ROOT-APP-NPM-CVE-2026-102829"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js Git library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the VISUAL environment variable in simple-git if the application forwards attacker-controlled environment values.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection","id":"CVE-2026-102829","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)","id":"CVE-2026-102830"},"packages":[{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"@simple-git/argv-parser","purl":null,"source":"GHSA-v5rq-49vh-5v5c"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"@simple-git/argv-parser","purl":"pkg:npm/%40simple-git/argv-parser","source":"GHSA-v5rq-49vh-5v5c"}],"prev":{"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828"},"products":["git-js"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["steveukx"]},"summary":"Attackers can execute arbitrary code via the VISUAL environment variable in simple-git if the application forwards attacker-controlled environment values.","url":"https://insights.sbomify.com/CVE-2026-102829/"}