# CVE-2026-102829: simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection

> Attackers can execute arbitrary code via the VISUAL environment variable in simple-git if the application forwards attacker-controlled environment values.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** CLEANSTART-2026-ES51269, CLEANSTART-2026-IX68198, CLSA-2026-1792595414, ECHO-bb3c-f0fd-74d5, GHSA-v5rq-49vh-5v5c, MINI-5cqr-37cc-7rc6, MINI-hjcf-rwp7-qg9r, ROOT-APP-NPM-CVE-2026-102829

## What is CVE-2026-102829?

CVE-2026-102829 is a critical command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-102829?

2 open source packages ship an affected version, including @simple-git/argv-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@simple-git/argv-parser` | npm | All versions | 2.0.1 |
| `@simple-git/argv-parser` | npm | All versions | 2.0.1 |

## How do I fix CVE-2026-102829?

Upgrade @simple-git/argv-parser to 2.0.1 or later.

## Is CVE-2026-102829 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102829 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102829 and fix it if it is affected.

What it is: CVE-2026-102829 is a critical command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102829 exists.

Affected packages and fixed versions:
- @simple-git/argv-parser (npm): affected all versions; fixed in 2.0.1
- @simple-git/argv-parser (npm): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102829/ (Markdown: https://insights.sbomify.com/CVE-2026-102829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102829
- OSV: https://osv.dev/vulnerability/CVE-2026-102829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102829/
Summaries are generated and may contain mistakes; the official description above is the record.
