{"answers":{"affected":"8 open source packages ship an affected version, including jupyterlab and jupyterlite-core.","exploited":"There is no known exploitation of CVE-2026-102830 in the wild and no public exploit code.","fix":"Upgrade jupyterlab to a fixed version for your release line: 4.5.11 or 4.6.4.","what":"CVE-2026-102830 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-102830 and fix it if it is affected.\n\nWhat it is: CVE-2026-102830 is a medium-severity cross-site scripting vulnerability in jupyterlab, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-102830 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterlab (PyPI): affected from 3.0.0; fixed in 4.5.11, 4.6.4\n- jupyterlab (PyPI): affected from 3.0.0; fixed in 4.5.11\n- jupyterlab (PyPI): affected from 3.0.0; fixed in 4.5.11\n- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.4\n- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.4\n- jupyterlite-core (PyPI): affected all versions; fixed in 0.8.4\n- jupyterlite-core (PyPI): affected all versions; fixed in 0.8.4\n- jupyterlite-core (PyPI): affected all versions; fixed in 0.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102830/ (Markdown: https://insights.sbomify.com/CVE-2026-102830/index.md)","id":"CVE-2026-102830","markdown":"https://insights.sbomify.com/CVE-2026-102830/index.md","name":"CVE-2026-102830","record":{"aliases":["DEBIAN-CVE-2026-102830","GHSA-3jqq-pw4j-pqcj","MINI-fcm2-x855-q9v4","MINI-prqr-h9x4-4f6w","PYSEC-2026-4056","PYSEC-2026-4059","UBUNTU-CVE-2026-102830"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterLab web interface","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in JupyterLab via malicious language packs, potentially accessing server APIs to read or modify files.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0 until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the Plural-Forms header in a selected third-party language pack can append JavaScript after a valid plural rule because prefix-only regular-expression validation accepts a matching prefix without requiring the entire header to match. JupyterLab passes the accepted expression to new Function, so loading the catalogue and translating a plural string executes the appended code in the authenticated JupyterLab origin. Where Jupyter Server kernels, terminals, and APIs are exposed, the code can use authenticated server APIs to read or modify files and run code. Impact is much more limited in JupyterLite because it typically lacks most exposed Jupyter Server surfaces. The default English locale is unaffected because it does not load a translation catalogue. This issue is fixed in JupyterLab 4.5.11 and 4.6.4 and JupyterLite Core 0.8.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)","id":"CVE-2026-102830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":8,"n_references":6,"next":{"headline":"JupyterLab: Cross-site scripting (XSS) in JupyterLab via notebook cells pasted from the system clipboard","id":"CVE-2026-102831"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.11","4.6.4"],"introduced":["3.0.0","4.6.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"PYSEC-2026-4056"},{"ecosystem":"PyPI","fixed":["4.5.11"],"introduced":["3.0.0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["4.5.11"],"introduced":["3.0.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["4.6.4"],"introduced":["4.6.0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["4.6.4"],"introduced":["4.6.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"jupyterlite-core","purl":null,"source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"jupyterlite-core","purl":"pkg:pypi/jupyterlite-core","source":"GHSA-3jqq-pw4j-pqcj"},{"ecosystem":"PyPI","fixed":["0.8.4"],"introduced":["0"],"last_affected":[],"package":"jupyterlite-core","purl":"pkg:pypi/jupyterlite-core","source":"PYSEC-2026-4059"}],"prev":{"headline":"simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection","id":"CVE-2026-102829"},"products":["jupyterlab","jupyterlite-core"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["jupyterlab"]},"summary":"Attackers can execute arbitrary JavaScript in JupyterLab via malicious language packs, potentially accessing server APIs to read or modify files.","url":"https://insights.sbomify.com/CVE-2026-102830/"}