{"answers":{"affected":"2 open source packages ship an affected version, including @enderfga/claw-orchestrator.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10291 exists.","fix":"Upgrade @enderfga/claw-orchestrator to 3.7.1 or later.","what":"CVE-2026-10291 is a medium-severity denial of service vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-10291 and fix it if it is affected.\n\nWhat it is: CVE-2026-10291 is a medium-severity denial of service vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10291 exists.\n\nAffected packages and fixed versions:\n- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.7.1\n- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10291/ (Markdown: https://insights.sbomify.com/CVE-2026-10291/index.md)","id":"CVE-2026-10291","markdown":"https://insights.sbomify.com/CVE-2026-10291/index.md","name":"CVE-2026-10291","record":{"aliases":["GHSA-95f6-rfpg-c3w8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"claw-orchestrator library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in claw-orchestrator by sending malicious regex patterns to the Session Grep endpoint.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A security vulnerability has been detected in Enderfga claw-orchestrator up to 3.7.0. The impacted element is the function validateRegex of the file claw-orchestrator/src/embedded-server.ts of the component Session Grep Endpoint. The manipulation of the argument body.pattern leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 3.7.1 is sufficient to resolve this issue. The identifier of the patch is 3f970a974c65a94555c25af9f2796f11315e4584. It is recommended to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Enderfga claw-orchestrator Session Grep Endpoint embedded-server.ts validateRegex redos","id":"CVE-2026-10291","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":9,"next":{"headline":"UTT HiPER 1200GW formTaskEdit strcpy stack-based overflow","id":"CVE-2026-10292"},"packages":[{"ecosystem":"npm","fixed":["3.7.1"],"introduced":["0"],"last_affected":[],"package":"@enderfga/claw-orchestrator","purl":null,"source":"GHSA-95f6-rfpg-c3w8"},{"ecosystem":"npm","fixed":["3.7.1"],"introduced":["0"],"last_affected":[],"package":"@enderfga/claw-orchestrator","purl":"pkg:npm/%40enderfga/claw-orchestrator","source":"GHSA-95f6-rfpg-c3w8"}],"prev":{"headline":"code-projects Hotel and Tourism Reservation System GET Parameter tour.php sql injection","id":"CVE-2026-10290"},"products":["claw-orchestrator"],"published":"2026-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-02","vendors":["Enderfga"]},"summary":"Remote attackers can cause denial of service in claw-orchestrator by sending malicious regex patterns to the Session Grep endpoint.","url":"https://insights.sbomify.com/CVE-2026-10291/"}