# CVE-2026-10291: Enderfga claw-orchestrator Session Grep Endpoint embedded-server.ts validateRegex redos

> Remote attackers can cause denial of service in claw-orchestrator by sending malicious regex patterns to the Session Grep endpoint.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-95f6-rfpg-c3w8

## What is CVE-2026-10291?

CVE-2026-10291 is a medium-severity denial of service vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security vulnerability has been detected in Enderfga claw-orchestrator up to 3.7.0. The impacted element is the function validateRegex of the file claw-orchestrator/src/embedded-server.ts of the component Session Grep Endpoint. The manipulation of the argument body.pattern leads to inefficient regular expression complexity. The attack may be initiated remotely. Upgrading to version 3.7.1 is sufficient to resolve this issue. The identifier of the patch is 3f970a974c65a94555c25af9f2796f11315e4584. It is recommended to upgrade the affected component.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-10291?

2 open source packages ship an affected version, including @enderfga/claw-orchestrator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@enderfga/claw-orchestrator` | npm | All versions | 3.7.1 |
| `@enderfga/claw-orchestrator` | npm | All versions | 3.7.1 |

## How do I fix CVE-2026-10291?

Upgrade @enderfga/claw-orchestrator to 3.7.1 or later.

## Is CVE-2026-10291 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10291 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10291 and fix it if it is affected.

What it is: CVE-2026-10291 is a medium-severity denial of service vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10291 exists.

Affected packages and fixed versions:
- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.7.1
- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10291/ (Markdown: https://insights.sbomify.com/CVE-2026-10291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10291
- OSV: https://osv.dev/vulnerability/CVE-2026-10291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10291/
Summaries are generated and may contain mistakes; the official description above is the record.
