{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102911 exists.","fix":"No fix has been published for CVE-2026-102911 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-102911 is a critical command injection vulnerability in zosmaai pi-llm-wiki, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102911 and fix it if it is affected.\n\nWhat it is: CVE-2026-102911 is a critical command injection vulnerability in zosmaai pi-llm-wiki, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102911 exists.\n\nAffected product: zosmaai pi-llm-wiki. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102911/ (Markdown: https://insights.sbomify.com/CVE-2026-102911/index.md)","id":"CVE-2026-102911","markdown":"https://insights.sbomify.com/CVE-2026-102911/index.md","name":"CVE-2026-102911","record":{"aliases":["GHSA-jcgm-7m3g-h3cx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"pi-llm-wiki MCP tool","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary OS commands via the url argument in the wiki_capture_source MCP tool of pi-llm-wiki.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7. Affected is an unknown function of the file mcp/index.ts of the component wiki_capture_source MCP tool. Executing a manipulation of the argument url can lead to os command injection. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 0.11.8 is able to address this issue. This patch is called 360867034e79175b45c8e04a98e4ca712bbaca35. Upgrading the affected component is advised.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"zosmaai pi-llm-wiki wiki_capture_source MCP tool index.ts os command injection","id":"CVE-2026-102911","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":9,"next":{"headline":"SourceCodester Online Leave Management System page reports sql injection","id":"CVE-2026-102912"},"packages":[],"prev":{"headline":"SourceCodester Online Reviewer Management System exam-delete.php sql injection","id":"CVE-2026-102910"},"products":["pi-llm-wiki"],"published":"2026-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["zosmaai"]},"summary":"Remote attackers can execute arbitrary OS commands via the url argument in the wiki_capture_source MCP tool of pi-llm-wiki.","url":"https://insights.sbomify.com/CVE-2026-102911/"}