# CVE-2026-102911: zosmaai pi-llm-wiki wiki_capture_source MCP tool index.ts os command injection

> Remote attackers can execute arbitrary OS commands via the url argument in the wiki_capture_source MCP tool of pi-llm-wiki.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-jcgm-7m3g-h3cx

## What is CVE-2026-102911?

CVE-2026-102911 is a critical command injection vulnerability in zosmaai pi-llm-wiki, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7. Affected is an unknown function of the file mcp/index.ts of the component wiki_capture_source MCP tool. Executing a manipulation of the argument url can lead to os command injection. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 0.11.8 is able to address this issue. This patch is called 360867034e79175b45c8e04a98e4ca712bbaca35. Upgrading the affected component is advised.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-102911?


## How do I fix CVE-2026-102911?

No fix has been published for CVE-2026-102911 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102911 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102911 and fix it if it is affected.

What it is: CVE-2026-102911 is a critical command injection vulnerability in zosmaai pi-llm-wiki, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102911 exists.

Affected product: zosmaai pi-llm-wiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102911/ (Markdown: https://insights.sbomify.com/CVE-2026-102911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102911
- OSV: https://osv.dev/vulnerability/CVE-2026-102911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102911/
Summaries are generated and may contain mistakes; the official description above is the record.
