# CVE-2026-102938: virtualenv writes prompt values into pyvenv.cfg without sanitizing line boundaries, allowing configuration injection

> Attackers can inject configuration keys into pyvenv.cfg via prompt values, potentially forcing the use of a malicious base interpreter.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** AZL-105672, BIT-virtualenv-2026-102938, DEBIAN-CVE-2026-102938, ECHO-50c8-2dcc-b664, GHSA-9h9j-4vrj-gf7g, MINI-cxmx-fcq7-hcg4, MINI-g3f9-r4wj-x74j, PYSEC-2026-4012, UBUNTU-CVE-2026-102938

## What is CVE-2026-102938?

CVE-2026-102938 is a medium-severity vulnerability in pypa virtualenv, published on 29 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.7.11, PyEnvCfg.write() writes prompt values verbatim to the line-oriented pyvenv.cfg format while PyEnvCfg._read_values() parses the file with str.splitlines() and accepts the last value for duplicate keys. An attacker who influences --prompt, VIRTUALENV_PROMPT, or configuration input can insert a recognized line boundary and additional keys, including home, causing consumers to use an attacker-selected base interpreter or corrupted environment metadata. The security impact requires prompt input from outside the operator's trust boundary; directly supplied prompt content primarily corrupts the operator's own environment. This issue is fixed in version 21.7.11.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-102938?

4 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.7.11 |
| `virtualenv` | PyPI | All versions | 21.7.11 |
| `virtualenv` | PyPI | All versions | 21.7.11 |
| `virtualenv` | PyPI | All versions | 21.7.11 |

## How do I fix CVE-2026-102938?

Upgrade virtualenv to 21.7.11 or later.

## Is CVE-2026-102938 being exploited?

There is no known exploitation of CVE-2026-102938 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102938 and fix it if it is affected.

What it is: CVE-2026-102938 is a medium-severity vulnerability in pypa virtualenv, published on 29 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-102938 in the wild and no public exploit code.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.7.11
- virtualenv (PyPI): affected all versions; fixed in 21.7.11
- virtualenv (PyPI): affected all versions; fixed in 21.7.11
- virtualenv (PyPI): affected all versions; fixed in 21.7.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102938/ (Markdown: https://insights.sbomify.com/CVE-2026-102938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102938
- OSV: https://osv.dev/vulnerability/CVE-2026-102938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102938/
Summaries are generated and may contain mistakes; the official description above is the record.
