{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10294 exists.","fix":"Apply the vendor's patch.","what":"CVE-2026-10294 is a medium-severity missing authorization vulnerability in PackageKit, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-10294 and fix it if it is affected.\n\nWhat it is: CVE-2026-10294 is a medium-severity missing authorization vulnerability in PackageKit, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10294 exists.\n\nAffected product: PackageKit. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-10294/ (Markdown: https://insights.sbomify.com/CVE-2026-10294/index.md)","id":"CVE-2026-10294","markdown":"https://insights.sbomify.com/CVE-2026-10294/index.md","name":"CVE-2026-10294","record":{"aliases":["DEBIAN-CVE-2026-10294","GHSA-9m6p-w8rp-5v54","MGASA-2026-0411","OESA-2026-2689","SUSE-SU-2026:22860-1","SUSE-SU-2026:3404-1","SUSE-SU-2026:3405-1","UBUNTU-CVE-2026-10294","openSUSE-SU-2026:11406-1","openSUSE-SU-2026:21425-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PackageKit package manager","requires_auth":"low_privilege","summary":"Attackers can bypass authorization checks in PackageKit's transaction API to potentially escalate privileges or bypass security controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability has been found in PackageKit up to 1.3.5. Affected is the function g_file_test of the file src/pk-transaction.c of the component API. Such manipulation of the argument frontend-socket leads to improper authorization. The attack can be executed remotely. The exploit has been disclosed to the public and may be used.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Enterprise Workstation Extension 15 SP7","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PackageKit API pk-transaction.c g_file_test improper authorization","id":"CVE-2026-10294","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":7,"n_references":6,"next":{"headline":"SourceCodester Customer Review App review_app.py get_all_reviews denial of service","id":"CVE-2026-10295"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP7","fixed":["1.2.8-150600.4.17.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/suse/PackageKit\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP7","source":"SUSE-SU-2026:3404-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["1.2.8-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/suse/PackageKit\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22860-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["1.1.3-24.26.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/suse/PackageKit\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:3405-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["1.2.8-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/suse/PackageKit\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22860-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 15 SP7","fixed":["1.2.8-150600.4.17.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/suse/PackageKit\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2015%20SP7","source":"SUSE-SU-2026:3404-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.2.8-160000.5.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/opensuse/PackageKit\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21425-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.6-1.1"],"introduced":["0"],"last_affected":[],"package":"PackageKit","purl":"pkg:rpm/opensuse/PackageKit\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11406-1"}],"prev":{"headline":"UTT HiPER 1200GW formFireWall strcpy stack-based overflow","id":"CVE-2026-10293"},"products":["PackageKit"],"published":"2026-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-02","vendors":["n/a"]},"summary":"Attackers can bypass authorization checks in PackageKit's transaction API to potentially escalate privileges or bypass security controls.","url":"https://insights.sbomify.com/CVE-2026-10294/"}