# CVE-2026-102982: Plane: XSS in work item comments

> An attacker can execute arbitrary scripts in another user's browser via unsanitized URLs in project comments, potentially leading to account takeover.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-6qrq-f73q-r67j

## What is CVE-2026-102982?

CVE-2026-102982 is a high-severity cross-site scripting vulnerability in makeplane plane, published on 13 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Plane is an open-source project management tool. Prior to 1.4.0, the plane comments fail to sanitize unsafe URL schemes stored in comment_html. A project member can store a crafted link in a comment, and attacker-controlled script executes in the browser context of another user who selects the link. This issue is fixed in version 1.4.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-102982?


## How do I fix CVE-2026-102982?

No fix has been published for CVE-2026-102982 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102982 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102982 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102982 and fix it if it is affected.

What it is: CVE-2026-102982 is a high-severity cross-site scripting vulnerability in makeplane plane, published on 13 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102982 exists.

Affected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102982/ (Markdown: https://insights.sbomify.com/CVE-2026-102982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102982
- OSV: https://osv.dev/vulnerability/CVE-2026-102982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102982/
Summaries are generated and may contain mistakes; the official description above is the record.
