# CVE-2026-102989: TanStack Router: Unauthenticated reflected XSS in TanStack Start server-function responses

> An unauthenticated attacker can inject malicious scripts via crafted server-function URLs, allowing same-origin data access and request execution on victim browsers.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-qx66-fv34-fjm8

## What is CVE-2026-102989?

CVE-2026-102989 is a critical cross-site scripting vulnerability in @tanstack react-start, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TanStack Router is a client-first, server-capable, fully type-safe router and full-stack framework for the web. From 1.143.12 until 1.169.39 for @tanstack/start-server-core, 1.168.60 for @tanstack/react-start, 1.168.57 for @tanstack/solid-start, and 1.168.56 for @tanstack/vue-start, an unauthenticated attacker can place non-public fields in a server-function request payload so that attacker-controlled middleware state reaches the error path and a response-shaped object is accepted as an HTTP response. A crafted server-function URL can therefore return attacker-controlled HTML from the application's origin; when a visitor opens the URL, the injected script can access same-origin data and issue requests with the visitor's authority. This issue is fixed in @tanstack/start-server-core 1.169.39, @tanstack/react-start 1.168.60, @tanstack/solid-start 1.168.57, and @tanstack/vue-start 1.168.56.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-102989?

8 open source packages ship an affected version, including @tanstack/react-start, @tanstack/solid-start and @tanstack/start-server-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tanstack/react-start` | npm | From 1.143.12 | 1.168.60 |
| `@tanstack/react-start` | npm | From 1.143.12 | 1.168.60 |
| `@tanstack/solid-start` | npm | From 1.143.12 | 1.168.57 |
| `@tanstack/solid-start` | npm | From 1.143.12 | 1.168.57 |
| `@tanstack/start-server-core` | npm | From 1.143.12 | 1.169.39 |
| `@tanstack/start-server-core` | npm | From 1.143.12 | 1.169.39 |
| `@tanstack/vue-start` | npm | From 1.143.12 | 1.168.56 |
| `@tanstack/vue-start` | npm | From 1.143.12 | 1.168.56 |

## How do I fix CVE-2026-102989?

Upgrade @tanstack/react-start to 1.168.60 or later.

## Is CVE-2026-102989 being exploited?

There is no known exploitation of CVE-2026-102989 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102989 and fix it if it is affected.

What it is: CVE-2026-102989 is a critical cross-site scripting vulnerability in @tanstack react-start, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-102989 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tanstack/react-start (npm): affected from 1.143.12; fixed in 1.168.60
- @tanstack/react-start (npm): affected from 1.143.12; fixed in 1.168.60
- @tanstack/solid-start (npm): affected from 1.143.12; fixed in 1.168.57
- @tanstack/solid-start (npm): affected from 1.143.12; fixed in 1.168.57
- @tanstack/start-server-core (npm): affected from 1.143.12; fixed in 1.169.39
- @tanstack/start-server-core (npm): affected from 1.143.12; fixed in 1.169.39
- @tanstack/vue-start (npm): affected from 1.143.12; fixed in 1.168.56
- @tanstack/vue-start (npm): affected from 1.143.12; fixed in 1.168.56

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102989/ (Markdown: https://insights.sbomify.com/CVE-2026-102989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102989
- OSV: https://osv.dev/vulnerability/CVE-2026-102989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102989/
Summaries are generated and may contain mistakes; the official description above is the record.
