# CVE-2026-102993: pypdf: Possible large memory usage when retrieving Roman page labels

> Attackers can cause denial of service in applications using pypdf by providing crafted PDFs with large Roman page labels, leading to excessive memory consumption.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-102993, ECHO-3c06-54a1-772f, GHSA-qv6h-rv94-w285, MINI-22h4-j2jq-9j49, MINI-3w8h-2v3r-289h, MINI-4fj3-xf43-68mq, MINI-7w84-c5jh-7rh2, MINI-9xgr-h5vr-6r8w, MINI-c5x7-3v9p-vhxw, MINI-fwfc-f439-vfj9, MINI-jmrw-hcp3-h7v9, MINI-mg4p-5v8p-q5wv, MINI-pf67-wr92-x8mm, MINI-r7rj-7w38-4prf, MINI-rg5g-r58c-r7h5, MINI-wgx6-crw6-vv62, PYSEC-2026-4158, ROOT-APP-PYPI-CVE-2026-102993, UBUNTU-CVE-2026-102993

## What is CVE-2026-102993?

CVE-2026-102993 is a high-severity denial of service vulnerability in Pypdf Project Pypdf, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.17.0, a crafted PDF can provide unusually large Roman page-label values that cause pypdf/_page_labels.py to generate excessively large numeral strings when an application retrieves document page labels, consuming large amounts of memory and potentially making the application unavailable. This issue is fixed in version 6.17.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102993?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.17.0 |
| `pypdf` | PyPI | All versions | 6.17.0 |
| `pypdf` | PyPI | All versions | 6.17.0 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-102993?

Upgrade pypdf to 6.17.0 or later.

## Is CVE-2026-102993 being exploited?

There is no known exploitation of CVE-2026-102993 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)
- [CVE-2026-102998](https://insights.sbomify.com/CVE-2026-102998/): pypdf: Possible long runtimes when generating appearance streams (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102993 and fix it if it is affected.

What it is: CVE-2026-102993 is a high-severity denial of service vulnerability in Pypdf Project Pypdf, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102993 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.17.0
- pypdf (PyPI): affected all versions; fixed in 6.17.0
- pypdf (PyPI): affected all versions; fixed in 6.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102993/ (Markdown: https://insights.sbomify.com/CVE-2026-102993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102993
- OSV: https://osv.dev/vulnerability/CVE-2026-102993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102993/
Summaries are generated and may contain mistakes; the official description above is the record.
