# CVE-2026-102994: pypdf: Possible long runtimes/large memory usage when parsing indirect objects

> Attackers can cause denial of service in applications using pypdf by providing crafted PDFs that trigger excessive resource consumption during parsing.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-102994, ECHO-c967-d15b-9485, GHSA-5jq2-8x83-x246, MINI-3m7f-659x-gp2p, MINI-83w4-426q-xj69, MINI-96mc-q9g5-gw2c, MINI-chwh-34rm-f76g, MINI-fc5w-6p3m-7f9q, MINI-gqr8-4w2r-vr7m, MINI-h999-9gcx-vv4x, MINI-hf6r-4794-3h89, MINI-mv2r-c75r-jmxm, MINI-p88q-cpj8-jhx9, MINI-q7pg-j6jp-wvw5, MINI-rrvj-hgrp-8jv8, MINI-x29q-j86q-xwg4, PYSEC-2026-4153, ROOT-APP-PYPI-CVE-2026-102994, UBUNTU-CVE-2026-102994

## What is CVE-2026-102994?

CVE-2026-102994 is a high-severity denial of service vulnerability in Pypdf Project Pypdf, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.18.0, a crafted PDF containing indirect-object identifiers or generation-number tokens that continue for a long time without whitespace can cause pypdf/_reader.py and pypdf/generic/_base.py to scan excessive input through read_until_whitespace, resulting in long runtimes and application unavailability. This issue is fixed in version 6.18.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102994?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.18.0 |
| `pypdf` | PyPI | All versions | 6.18.0 |
| `pypdf` | PyPI | All versions | 6.18.0 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-102994?

Upgrade pypdf to 6.18.0 or later.

## Is CVE-2026-102994 being exploited?

There is no known exploitation of CVE-2026-102994 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)
- [CVE-2026-102998](https://insights.sbomify.com/CVE-2026-102998/): pypdf: Possible long runtimes when generating appearance streams (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102994 and fix it if it is affected.

What it is: CVE-2026-102994 is a high-severity denial of service vulnerability in Pypdf Project Pypdf, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102994 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.18.0
- pypdf (PyPI): affected all versions; fixed in 6.18.0
- pypdf (PyPI): affected all versions; fixed in 6.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102994/ (Markdown: https://insights.sbomify.com/CVE-2026-102994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102994
- OSV: https://osv.dev/vulnerability/CVE-2026-102994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102994/
Summaries are generated and may contain mistakes; the official description above is the record.
