# CVE-2026-103004: next.js cache leak on warm `use cache` handlers accessing root param

> Next.js cache keying flaw allows leaking cached content across different root parameters when Cache Components are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** CLEANSTART-2026-MS47438, CLEANSTART-2026-SE76644, GHSA-h694-7cp9-m8p3

## What is CVE-2026-103004?

CVE-2026-103004 is a medium-severity vulnerability in Vercel Next.js, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js versions from 16.3.0 to 16.3.7 warm `use cache` handlers using `next/root-params` and can leak their return value to pages with different root params. With Cache Components enabled (cacheComponents: true), a 'use cache' function that calls another 'use cache' function that reads a root param can be keyed incorrectly when the inner call is served from an existing entry: the enclosing function's cache key then omits that root param. The enclosing entry is written once and reused for all root param values, so a response for one root param value can serve content produced for a different value — whether the page is prerendered at build time or at runtime, or rendered dynamically. Shared cache headers let downstream caches redistribute the content further.

What values are leaked cannot be attacker controlled. Which value's content is served depends only on which invocation wrote the entry first.

This has been patched in 16.3.8.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-103004?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 16.3.0 | 16.3.8 |
| `next` | npm | From 16.3.0 | 16.3.8 |

Products: Vercel Next.js.

## How do I fix CVE-2026-103004?

Upgrade next to 16.3.8 or later.

## Is CVE-2026-103004 being exploited?

There is no known exploitation of CVE-2026-103004 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103004 and fix it if it is affected.

What it is: CVE-2026-103004 is a medium-severity vulnerability in Vercel Next.js, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103004 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 16.3.0; fixed in 16.3.8
- next (npm): affected from 16.3.0; fixed in 16.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103004/ (Markdown: https://insights.sbomify.com/CVE-2026-103004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103004
- OSV: https://osv.dev/vulnerability/CVE-2026-103004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103004/
Summaries are generated and may contain mistakes; the official description above is the record.
