CVE-2026-103009 Authorization Bypass Through User-Controlled Key in Elasticsearch Leading to Information Disclosure
Attackers with cross-cluster API keys can bypass authorization to read or modify unauthorized indices via crafted search requests.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-103009?
CVE-2026-103009 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Authorization Bypass Through User-Controlled Key (CWE-639) in Elasticsearch can lead to Information Disclosure via a specially crafted cross-cluster search request that references an unauthorized shard identifier. Elasticsearch contains an authorization bypass weakness in its handling of cross-cluster search requests made through the Remote Cluster Security (RCS) 2.0 model. An authorization check validates a request against one identifying attribute of the target shard, while a separate, independently-supplied identifying attribute in the same request determines which shard is actually accessed. A holder of a cross-cluster API key authorized for one index can craft a request whose two identifying attributes refer to different indices, causing the request to be authorized against an index they can access while actually operating against a different, unauthorized index. This can expose that index's document contents, field mappings, and other metadata, and in limited cases allows modification of retention-lease state on the unauthorized index.
Weakness: CWE-639
Which versions are affected by CVE-2026-103009?
1 open source package ship an affected version, including elasticsearch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
elasticsearch Bitnami | From 8.13.0 | 8.19.23, 9.4.8, 9.5.5 |
Products include Elastic Elasticsearch.
How do I fix CVE-2026-103009?
Upgrade elasticsearch to a fixed version for your release line: 8.19.23, 9.4.8 or 9.5.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-103009 being exploited?
There is no known exploitation of CVE-2026-103009 in the wild and no public exploit code.
Other vulnerabilities in Elastic Elasticsearch
- CVE-2015-1427 Elasticsearch Groovy Scripting Engine Remote Code Execution
- CVE-2014-3120 Elasticsearch Remote Code Execution
- CVE-2015-5377 Code injection in n/a
- CVE-2026-72649 Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution
- CVE-2026-72642 Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process
Sources
Also known as BIT-elasticsearch-2026-103009, CLEANSTART-2026-QV23882, GHSA-jh46-59x3-g5qh, MINI-2v54-rgj4-wvj4, MINI-3645-2fq8-9f6r, MINI-38wp-6h32-xv2j and 18 more.