# CVE-2026-103009: Authorization Bypass Through User-Controlled Key in Elasticsearch Leading to Information Disclosure

> Attackers with cross-cluster API keys can bypass authorization to read or modify unauthorized indices via crafted search requests.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-elasticsearch-2026-103009, CLEANSTART-2026-QV23882, GHSA-jh46-59x3-g5qh, MINI-2v54-rgj4-wvj4, MINI-3645-2fq8-9f6r, MINI-38wp-6h32-xv2j, MINI-4xpp-xx8w-4vww, MINI-62qv-h2g5-c388, MINI-948w-6m96-hv76, MINI-9p6r-2q38-8g6v, MINI-cwgp-6p47-xx48, MINI-f996-hw3c-vvpx, MINI-g8wh-4392-ffc4, MINI-gw94-2hjx-3rqx, MINI-gx8q-mh3v-9w2p, MINI-mjm2-9mcf-rx55, MINI-q72v-fghj-7854, MINI-qpmq-jpcv-9vrj, MINI-v27p-89w9-8xrv, MINI-wpc9-448m-6fx5, MINI-wr8p-c58h-4wr9, MINI-wrmm-c25x-q6m2, MINI-x84h-24w8-wpjg, MINI-xfv2-whm5-rh2j

## What is CVE-2026-103009?

CVE-2026-103009 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization Bypass Through User-Controlled Key (CWE-639) in Elasticsearch can lead to Information Disclosure via a specially crafted cross-cluster search request that references an unauthorized shard identifier. Elasticsearch contains an authorization bypass weakness in its handling of cross-cluster search requests made through the Remote Cluster Security (RCS) 2.0 model. An authorization check validates a request against one identifying attribute of the target shard, while a separate, independently-supplied identifying attribute in the same request determines which shard is actually accessed. A holder of a cross-cluster API key authorized for one index can craft a request whose two identifying attributes refer to different indices, causing the request to be authorized against an index they can access while actually operating against a different, unauthorized index. This can expose that index's document contents, field mappings, and other metadata, and in limited cases allows modification of retention-lease state on the unauthorized index.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-103009?

1 open source package ship an affected version, including elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elasticsearch` | Bitnami | From 8.13.0 | 8.19.23, 9.4.8, 9.5.5 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2026-103009?

Upgrade elasticsearch to a fixed version for your release line: 8.19.23, 9.4.8 or 9.5.5.

## Is CVE-2026-103009 being exploited?

There is no known exploitation of CVE-2026-103009 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103009 and fix it if it is affected.

What it is: CVE-2026-103009 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 6 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103009 in the wild and no public exploit code.

Affected packages and fixed versions:
- elasticsearch (Bitnami): affected from 8.13.0; fixed in 8.19.23, 9.4.8, 9.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103009/ (Markdown: https://insights.sbomify.com/CVE-2026-103009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103009
- OSV: https://osv.dev/vulnerability/CVE-2026-103009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103009/
Summaries are generated and may contain mistakes; the official description above is the record.
