# CVE-2026-103030: Dio: Cross-origin redirect leaks sensitive request headers in `dio_http2_adapter`

> A malicious server can leak sensitive headers like Authorization and Cookies to a different origin via cross-origin redirects in the Dio HTTP client.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-cr65-55v9-xhvv

## What is CVE-2026-103030?

CVE-2026-103030 is a high-severity vulnerability in cfug dio, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dio is a powerful HTTP client for Dart and Flutter. From 1.0.0 until 2.8.0, dio_http2_adapter follows redirects in Http2Adapter._fetch by copying the original RequestOptions.headers into the redirected HTTP/2 request without comparing the source and destination origins. A server contacted by an application can return a cross-origin Location redirect to a different-origin destination, which then receives preserved Authorization, Cookie, and Proxy-Authorization headers because RequestOptions.copyWith retains the full header map. The issue applies when applications use Http2Adapter for authenticated requests, and redirect following is enabled by default. This issue is fixed in version 2.8.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-103030?

2 open source packages ship an affected version, including dio_http2_adapter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dio_http2_adapter` | Pub | From 1.0.0 | 2.8.0 |
| `dio_http2_adapter` | Pub | From 1.0.0 | 2.8.0 |

## How do I fix CVE-2026-103030?

Upgrade dio_http2_adapter to 2.8.0 or later.

## Is CVE-2026-103030 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103030 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103030 and fix it if it is affected.

What it is: CVE-2026-103030 is a high-severity vulnerability in cfug dio, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103030 exists.

Affected packages and fixed versions:
- dio_http2_adapter (Pub): affected from 1.0.0; fixed in 2.8.0
- dio_http2_adapter (Pub): affected from 1.0.0; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103030/ (Markdown: https://insights.sbomify.com/CVE-2026-103030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103030
- OSV: https://osv.dev/vulnerability/CVE-2026-103030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103030/
Summaries are generated and may contain mistakes; the official description above is the record.
