# CVE-2026-103090: Unauthenticated Biscuit Credential Disclosure via GET /enroll/status in Google OSS Agent Mesh (SAM)


- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-hp3x-79wr-rx66, GHSA-xhg2-hv24-f4rp

## What is CVE-2026-103090?

CVE-2026-103090 is a high-severity vulnerability in Google SAM, published on 21 Oct 2026. 

### Official description

Missing Authentication for Critical Function (CWE-306) and Insufficiently Protected Credentials (CWE-522) in the control plane enrollment status handler (HandleEnrollStatus at GET /enroll/status in internal/controlplane/server.go) in Google OSS Agent Mesh (SAM) versions 0.1.0-alpha.1 through 0.1.0-alpha.8 allow an unauthenticated remote attacker to retrieve an approved bootstrap-enrolled peer's signed Biscuit identity token by supplying a peer_id obtainable from the unauthenticated GET /info endpoint. A related flaw in POST /enroll allowed any bootstrap-token holder to re-fetch another peer's credential. An attacker can replay the disclosed Biscuit token as a bearer credential on /policies to read mesh authorization policies and on /routers/lease to overwrite advertised router multiaddrs. Users should upgrade to version 0.1.0-alpha.9 or later, which requires cryptographic proof of possession of the enrollment private key on credential-releasing endpoints, enforces rate limiting, and validates router lease addresses.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-103090?


## How do I fix CVE-2026-103090?

No fix has been published for CVE-2026-103090 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103090 being exploited?

There is no known exploitation of CVE-2026-103090 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103090 and fix it if it is affected.

What it is: CVE-2026-103090 is a high-severity vulnerability in Google SAM, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-103090 in the wild and no public exploit code.

Affected product: Google SAM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103090/ (Markdown: https://insights.sbomify.com/CVE-2026-103090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103090
- OSV: https://osv.dev/vulnerability/CVE-2026-103090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103090/
Summaries are generated and may contain mistakes; the official description above is the record.
