{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-103118 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-103118 is a medium-severity denial of service vulnerability in GraphicsMagick, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-103118 and fix it if it is affected.\n\nWhat it is: CVE-2026-103118 is a medium-severity denial of service vulnerability in GraphicsMagick, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-103118 in the wild and no public exploit code.\n\nAffected product: GraphicsMagick. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-103118/ (Markdown: https://insights.sbomify.com/CVE-2026-103118/index.md)","id":"CVE-2026-103118","markdown":"https://insights.sbomify.com/CVE-2026-103118/index.md","name":"CVE-2026-103118","record":{"aliases":["DEBIAN-CVE-2026-103118","ECHO-062b-0761-fc27","GHSA-4c5c-7x65-ccwp","SUSE-SU-2026:4592-1","UBUNTU-CVE-2026-103118","openSUSE-SU-2026:12089-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphicsMagick image library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via uncontrolled recursion in the WPG file handler of GraphicsMagick.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"A vulnerability was detected in GraphicsMagick up to 1.3.47. Affected by this vulnerability is the function ExtractPostscript of the file coders/wpg.c of the component WPG File Handler. Performing a manipulation results in uncontrolled recursion. The attack may be initiated remotely. The patch is named 627b5b1b2fc2. It is suggested to install a patch to address this issue. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP7","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GraphicsMagick WPG File wpg.c ExtractPostscript recursion","id":"CVE-2026-103118","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"Apache Tomcat: AJP response mix-up","id":"CVE-2026-103119"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["1.3.42-150600.3.48.1"],"introduced":["0"],"last_affected":[],"package":"GraphicsMagick","purl":"pkg:rpm/suse/GraphicsMagick\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2026:4592-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.48-3.1"],"introduced":["0"],"last_affected":[],"package":"GraphicsMagick","purl":"pkg:rpm/opensuse/GraphicsMagick\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12089-1"}],"prev":{"headline":"OS4ED openSIS-Classic Save Data DatabaseInc.php db_properties sql injection","id":"CVE-2026-103117"},"products":["GraphicsMagick"],"published":"2026-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-02","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via uncontrolled recursion in the WPG file handler of GraphicsMagick.","url":"https://insights.sbomify.com/CVE-2026-103118/"}