# CVE-2026-103119: Apache Tomcat: AJP response mix-up


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-tomcat-2026-103119, DEBIAN-CVE-2026-103119, GHSA-64hx-4gc9-f6v4, UBUNTU-CVE-2026-103119

## What is CVE-2026-103119?

CVE-2026-103119 is a critical vulnerability in Apache Tomcat, published on 20 Oct 2026. 

### Official description

Buffer under-read vulnerability in Apache Tomcat meant that a large non-blocking write could result in the response body being split between the current request and the next request received on that connection leading most likely to failure of the second request and possibly leakage of data from the first response to the second.

This issue affects Apache Tomcat: from 11.0.0-M25 through 11.0.26.

Users are recommended to upgrade to version 11.0.27, which fixes the issue.

Weakness: CWE-127 (Buffer Under-read)

## Which versions are affected by CVE-2026-103119?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 11.0.0 | 11.0.27 |

## How do I fix CVE-2026-103119?

Upgrade tomcat to 11.0.27 or later.

## Is CVE-2026-103119 being exploited?

There is no known exploitation of CVE-2026-103119 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103119 and fix it if it is affected.

What it is: CVE-2026-103119 is a critical vulnerability in Apache Tomcat, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-103119 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 11.0.0; fixed in 11.0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103119/ (Markdown: https://insights.sbomify.com/CVE-2026-103119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103119
- OSV: https://osv.dev/vulnerability/CVE-2026-103119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103119/
Summaries are generated and may contain mistakes; the official description above is the record.
