# CVE-2026-103226: Artifex Ghostscript Pdfwrite gdevpsfx.c type1_callsubr stack-based overflow


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 15 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-103226, ECHO-ceca-1ac1-7ef7, GHSA-f9vm-qh24-w7rf, UBUNTU-CVE-2026-103226

## What is CVE-2026-103226?

CVE-2026-103226 is a medium-severity vulnerability in Artifex Ghostscript, published on 30 Sep 2026. 

### Official description

A vulnerability was identified in Artifex Ghostscript up to 10.07.0. Affected is the function type1_callsubr of the file devices/vector/gdevpsfx.c of the component Pdfwrite. The manipulation leads to stack-based buffer overflow. Remote exploitation of the attack is possible. The exploit is publicly available and might be used. Upgrading to version 10.08.0 is able to address this issue. It is suggested to upgrade the affected component. A solution was implemented: "I've chosen to fix this slightly differently by using the defined macro in the font parsing loop rather than in the callsubr function, because this better matches the pattern of 'normal' usage."

Weakness: CWE-121 (Stack-based Buffer Overflow), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-103226?


## How do I fix CVE-2026-103226?

Upgrade to a fixed version.

## Is CVE-2026-103226 being exploited?

There is no known exploitation of CVE-2026-103226 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103226 and fix it if it is affected.

What it is: CVE-2026-103226 is a medium-severity vulnerability in Artifex Ghostscript, published on 30 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-103226 in the wild and no public exploit code.

Affected product: Artifex Ghostscript. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103226/ (Markdown: https://insights.sbomify.com/CVE-2026-103226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103226
- OSV: https://osv.dev/vulnerability/CVE-2026-103226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103226/
Summaries are generated and may contain mistakes; the official description above is the record.
