CVE-2026-103241 vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service

Medium 6.9 Published Updated

Remote attackers can cause a denial of service in vLLM via the Gemma4UnifiedParser component, requiring an upgrade to resolve.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-103241?

CVE-2026-103241 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.

Weakness: CWE-404

Which versions are affected by CVE-2026-103241?

1 open source package ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions0.27.0

Products include Vllm Vllm.

How do I fix CVE-2026-103241?

Upgrade vllm to 0.27.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-103241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103241 exists.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-328r-mpfv-qc55, MINI-5857-xmwm-h8x5, MINI-cqpr-vj92-v87m, MINI-gfrr-9c58-7v4g, PYSEC-2026-4186.

Is CVE-2026-103241 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free