# CVE-2026-103241: vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service

> Remote attackers can cause a denial of service in vLLM via the Gemma4UnifiedParser component, requiring an upgrade to resolve.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-328r-mpfv-qc55, MINI-5857-xmwm-h8x5, MINI-cqpr-vj92-v87m, MINI-gfrr-9c58-7v4g, PYSEC-2026-4186

## What is CVE-2026-103241?

CVE-2026-103241 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2026-103241?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.27.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-103241?

Upgrade vllm to 0.27.0 or later.

## Is CVE-2026-103241 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103241 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103241 and fix it if it is affected.

What it is: CVE-2026-103241 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103241 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103241/ (Markdown: https://insights.sbomify.com/CVE-2026-103241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103241
- OSV: https://osv.dev/vulnerability/CVE-2026-103241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103241/
Summaries are generated and may contain mistakes; the official description above is the record.
