# CVE-2026-103261: Tornado before 6.5.9 Denial of Service via Query String

> Remote attackers can cause denial of service in Tornado web servers by sending requests with excessive query parameters, stalling the event loop.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** AZL-105372, BELL-CVE-2026-103261, CLEANSTART-2026-IM25560, DEBIAN-CVE-2026-103261, ECHO-5be6-c7b0-c3f1, GHSA-2v9w-f3h6-74rj, GHSA-3hv7-mjh2-fv65, MINI-23jx-2wv4-crr7, MINI-2fg6-6pqc-vm8x, MINI-37vx-2xx5-jqxh, MINI-43gx-jjjr-f2p6, MINI-4f47-p44f-pc2r, MINI-5r9g-93mp-x9qq, MINI-5xc2-7997-8px9, MINI-6rq8-jm2c-5ww5, MINI-7266-w294-pgrg, MINI-79x8-gwwg-r5vp, MINI-c2j9-65gr-x6w4, MINI-c8cp-xhw4-8mww, MINI-gf5g-qxqx-c653, MINI-px33-6px2-7m25, MINI-qmgp-r9cq-p4j7, MINI-rgm6-7jhw-jx2g, MINI-rgwq-66rc-jxqv, MINI-rqmg-mwpp-8f68, MINI-whqp-mjr5-7r24, MINI-wwmh-m5c8-c865, MINI-x86w-4grh-g9gm, UBUNTU-CVE-2026-103261

## What is CVE-2026-103261?

CVE-2026-103261 is a medium-severity denial of service vulnerability in tornadoweb tornado, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado before 6.5.9 fails to limit the number of query string fields in HTTPServerRequest.__init__, allowing remote attackers to cause event-loop stalling by sending requests with thousands of query parameters. Attackers can send unauthenticated GET requests with unbounded query-string field counts to degrade response times for all clients sharing the same IOLoop.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-103261?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.9 |
| `tornado` | PyPI | All versions | 6.5.9 |

## How do I fix CVE-2026-103261?

Upgrade tornado to 6.5.9 or later.

## Is CVE-2026-103261 being exploited?

There is no known exploitation of CVE-2026-103261 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103261 and fix it if it is affected.

What it is: CVE-2026-103261 is a medium-severity denial of service vulnerability in tornadoweb tornado, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103261 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.9
- tornado (PyPI): affected all versions; fixed in 6.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103261/ (Markdown: https://insights.sbomify.com/CVE-2026-103261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103261
- OSV: https://osv.dev/vulnerability/CVE-2026-103261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103261/
Summaries are generated and may contain mistakes; the official description above is the record.
