# CVE-2026-103262: Tornado before 6.5.9 Denial of Service via CurlAsyncHTTPClient

> Remote attackers can cause denial of service in Tornado applications by sending gzip-encoded decompression bombs that exhaust memory.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** ALSA-2026:82040, ALSA-2026:82041, AZL-105378, BELL-CVE-2026-103262, CLEANSTART-2026-IF03727, CLSA-2026-1790836708, CLSA-2026-1790846524, DEBIAN-CVE-2026-103262, ECHO-dd54-bdb8-4a69, GHSA-chx6-46f5-w4vp, GHSA-h36x-fm6v-f9vx, MINI-2ppw-5fp3-h354, MINI-2r73-43v7-j5v6, MINI-3q64-jp6c-rfr9, MINI-63x3-q8qw-xq8m, MINI-6f2r-cp5j-943c, MINI-75qc-jv49-h3v6, MINI-77xf-h2jq-jhwg, MINI-7jpm-w6g3-pg24, MINI-8cmm-45v4-mcf4, MINI-cf73-56x9-m6cm, MINI-f9c5-5jfp-945w, MINI-g74r-fjcg-4r8x, MINI-h2p3-c59p-cw5m, MINI-h6r7-4hfx-vw6r, MINI-hj84-2fv4-j8p6, MINI-mx6f-83hh-p353, MINI-q8qr-pq82-78qf, MINI-rg75-76w5-cfmh, MINI-w5xh-3xjw-4mgw, MINI-xqgg-fmvg-h828, MINI-xrmj-fcj4-324c, RHSA-2026:82040, RHSA-2026:82041, RLSA-2026:82040, RLSA-2026:82041, ROOT-APP-PYPI-GHSA-chx6-46f5-w4vp, UBUNTU-CVE-2026-103262

## What is CVE-2026-103262?

CVE-2026-103262 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado versions before 6.5.9 contain an unbounded memory accumulation vulnerability in CurlAsyncHTTPClient that allows remote attackers to cause denial of service by sending a compressed response. Attackers can send a gzip-encoded decompression bomb that accumulates in memory without size limits, causing the application process to be killed by out-of-memory conditions.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-103262?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.9 |
| `tornado` | PyPI | All versions | 6.5.9 |
| `python3-tornado` | AlmaLinux:10 | All versions | 6.5.10-1.el10_2.1 |
| `python3-tornado` | AlmaLinux:9 | All versions | 6.5.10-1.el9_8.1 |
| `python-tornado` | Red Hat:enterprise_linux:10.2 | All versions | 0:6.5.10-1.el10_2.1 |
| `python-tornado-debugsource` | Red Hat:enterprise_linux:10.2 | All versions | 0:6.5.10-1.el10_2.1 |
| `python3-tornado` | Red Hat:enterprise_linux:10.2 | All versions | 0:6.5.10-1.el10_2.1 |
| `python3-tornado-debuginfo` | Red Hat:enterprise_linux:10.2 | All versions | 0:6.5.10-1.el10_2.1 |
| `python-tornado` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.10-1.el9_8.1 |
| `python-tornado-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.10-1.el9_8.1 |
| `python3-tornado` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.10-1.el9_8.1 |
| `python3-tornado-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:6.5.10-1.el9_8.1 |
| `python-tornado` | Rocky Linux:10 | All versions | 0:6.5.10-1.el10_2.1 |
| `python-tornado` | Rocky Linux:9 | All versions | 0:6.5.10-1.el9_8.1 |

## How do I fix CVE-2026-103262?

Upgrade tornado to 6.5.9 or later.

## Is CVE-2026-103262 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103262 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103262 and fix it if it is affected.

What it is: CVE-2026-103262 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103262 exists.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.9
- tornado (PyPI): affected all versions; fixed in 6.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103262/ (Markdown: https://insights.sbomify.com/CVE-2026-103262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103262
- OSV: https://osv.dev/vulnerability/CVE-2026-103262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103262/
Summaries are generated and may contain mistakes; the official description above is the record.
