# CVE-2026-103272: Ghost 2.10.0 before 6.63.0 Staff Enumeration via Content API

> Unauthenticated attackers can enumerate staff members and leak user data via the Content API in Ghost CMS.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-ghost-2026-103272, GHSA-ffmj-3ppp-cj4r, GHSA-jh5v-v5x3-c3pp, MINI-xw3g-4p8f-wcj3

## What is CVE-2026-103272?

CVE-2026-103272 is a high-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ghost versions from 2.10.0 before 6.63.0 contain a staff enumeration vulnerability in the content API that allows unauthenticated attackers to leak user data. Attackers can observe discrepancies in API metadata responses to enumerate staff members and extract sensitive information without authentication.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2026-103272?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 2.10.0 | 6.63.0 |

## How do I fix CVE-2026-103272?

Upgrade ghost to 6.63.0 or later.

## Is CVE-2026-103272 being exploited?

There is no known exploitation of CVE-2026-103272 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103272 and fix it if it is affected.

What it is: CVE-2026-103272 is a high-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103272 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 2.10.0; fixed in 6.63.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103272/ (Markdown: https://insights.sbomify.com/CVE-2026-103272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103272
- OSV: https://osv.dev/vulnerability/CVE-2026-103272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103272/
Summaries are generated and may contain mistakes; the official description above is the record.
