# CVE-2026-103279: Ghost 3.10.0 before 6.34.0 Session Invalidation Bypass

> Attackers with stolen session cookies can maintain account access after password changes due to incomplete session invalidation in Ghost CMS.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 6 Oct 2026
- **Also known as:** BIT-ghost-2026-103279, GHSA-v827-452p-mh2j, GHSA-v9vj-6fq5-99xj

## What is CVE-2026-103279?

CVE-2026-103279 is a high-severity authentication bypass vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ghost versions from 3.10.0 before 6.34.0 fail to fully invalidate all sessions after a password change. Attackers with a stolen session cookie can maintain access to user accounts even after the associated user changes their password.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-103279?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 3.10.0 | 6.34.0 |

## How do I fix CVE-2026-103279?

Upgrade ghost to 6.34.0 or later.

## Is CVE-2026-103279 being exploited?

There is no known exploitation of CVE-2026-103279 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103279 and fix it if it is affected.

What it is: CVE-2026-103279 is a high-severity authentication bypass vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103279 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 3.10.0; fixed in 6.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103279/ (Markdown: https://insights.sbomify.com/CVE-2026-103279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103279
- OSV: https://osv.dev/vulnerability/CVE-2026-103279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103279/
Summaries are generated and may contain mistakes; the official description above is the record.
