# CVE-2026-103281: Ghost 3.23.0 before 6.23.0 API Key Exposure via Admin API

> Low-privilege staff users can read sensitive API keys via the Admin API, potentially bypassing security controls.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-ghost-2026-103281, GHSA-crq6-86x9-65hj, GHSA-q98w-jm4q-wch7

## What is CVE-2026-103281?

CVE-2026-103281 is a medium-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ghost (npm package 'ghost') versions from 3.23.0 up to, but not including, 6.23.0 expose API keys to users with low-privilege staff accounts. An authenticated low-privilege staff user can read API keys returned by the Admin API, which are intended to be available only to higher-privileged users.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-103281?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 3.23.0 | 6.23.0 |

## How do I fix CVE-2026-103281?

Upgrade ghost to 6.23.0 or later.

## Is CVE-2026-103281 being exploited?

There is no known exploitation of CVE-2026-103281 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103281 and fix it if it is affected.

What it is: CVE-2026-103281 is a medium-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103281 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 3.23.0; fixed in 6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103281/ (Markdown: https://insights.sbomify.com/CVE-2026-103281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103281
- OSV: https://osv.dev/vulnerability/CVE-2026-103281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103281/
Summaries are generated and may contain mistakes; the official description above is the record.
