# CVE-2026-103286: Ghost 2.21.0 before 6.56.0 Privilege Escalation via Notifications

> Low-privilege staff users can escalate to higher-privilege roles via the notifications system in Ghost CMS.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-ghost-2026-103286, GHSA-pv24-pfvg-vr83, GHSA-wmw5-238j-rqvj, MINI-j676-v342-f468

## What is CVE-2026-103286?

CVE-2026-103286 is a high-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation vulnerability in the notifications system that allows low-privilege staff users to escalate to higher-privilege staff roles. Attackers with low-privilege staff access can exploit the notifications system to gain elevated privileges without proper authorization checks.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-103286?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 2.21.0 | 6.56.0 |

## How do I fix CVE-2026-103286?

Upgrade ghost to 6.56.0 or later.

## Is CVE-2026-103286 being exploited?

There is no known exploitation of CVE-2026-103286 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103286 and fix it if it is affected.

What it is: CVE-2026-103286 is a high-severity vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-103286 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 2.21.0; fixed in 6.56.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103286/ (Markdown: https://insights.sbomify.com/CVE-2026-103286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103286
- OSV: https://osv.dev/vulnerability/CVE-2026-103286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103286/
Summaries are generated and may contain mistakes; the official description above is the record.
