# CVE-2026-103288: Ghost 5.9.0 before 6.44.1 Authorization Bypass via Comment Like

> Authenticated users can delete other users' comment likes, leading to unauthorized modification of engagement data in Ghost.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-ghost-2026-103288, GHSA-qrh6-cwg3-343x

## What is CVE-2026-103288?

CVE-2026-103288 is a high-severity missing authorization vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ghost, an open-source publishing platform, contains an input validation flaw in its comment like feature in versions from 5.9.0 before 6.44.1. An authenticated member can delete comment likes or dislikes belonging to other users that they are not authorized to delete, resulting in an authorization bypass and unauthorized modification of comment engagement data.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-103288?

3 open source packages ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 5.9.0 | 6.44.1 |
| `ghost` | npm | From 5.9.0 | 6.44.1 |
| `ghost` | npm | From 5.9.0 | 6.44.1 |

## How do I fix CVE-2026-103288?

Upgrade ghost to 6.44.1 or later.

## Is CVE-2026-103288 being exploited?

There is no known exploitation of CVE-2026-103288 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103288 and fix it if it is affected.

What it is: CVE-2026-103288 is a high-severity missing authorization vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103288 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 5.9.0; fixed in 6.44.1
- ghost (npm): affected from 5.9.0; fixed in 6.44.1
- ghost (npm): affected from 5.9.0; fixed in 6.44.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103288/ (Markdown: https://insights.sbomify.com/CVE-2026-103288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103288
- OSV: https://osv.dev/vulnerability/CVE-2026-103288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103288/
Summaries are generated and may contain mistakes; the official description above is the record.
