# CVE-2026-103292: Ghost 0.5.3 before 6.50.0 Cross-Site Scripting via ghost_head

> Authenticated users can inject scripts via the ghost_head helper, potentially stealing admin sessions from staff users viewing the page.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-ghost-2026-103292, GHSA-2549-6x67-jgrp, GHSA-mp9q-4q6m-44f5

## What is CVE-2026-103292?

CVE-2026-103292 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ghost versions from 0.5.3 through versions prior to 6.50.0 fail to sanitize the data placed in the JSON-LD HTML tag emitted by the {{ghost_head}} helper. An authenticated user with limited privileges can inject unescaped content that is rendered as script in the published page, potentially leading to compromise of a staff user's admin session when that user views the affected page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-103292?

1 open source package ship an affected version, including ghost.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 0.5.3 | 6.50.0 |

## How do I fix CVE-2026-103292?

Upgrade ghost to 6.50.0 or later.

## Is CVE-2026-103292 being exploited?

There is no known exploitation of CVE-2026-103292 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103292 and fix it if it is affected.

What it is: CVE-2026-103292 is a high-severity cross-site scripting vulnerability in TryGhost Ghost, published on 1 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-103292 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 0.5.3; fixed in 6.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103292/ (Markdown: https://insights.sbomify.com/CVE-2026-103292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103292
- OSV: https://osv.dev/vulnerability/CVE-2026-103292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103292/
Summaries are generated and may contain mistakes; the official description above is the record.
