CVE-2026-103505 AWS EFS CSI Driver Mount Option Injection via mounttargetipmap
Authenticated users with PersistentVolume creation permissions can inject arbitrary mount options, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-103505?
CVE-2026-103505 is a medium-severity command injection vulnerability in aws-efs-csi-driver, published on 1 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) v3.1.0 through v3.4.2 might allow remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma-separated values in the mounttargetipmap volumeAttribute.
To remediate this issue, users should upgrade to version v3.5.0 or later.
Weakness: CWE-88
Which versions are affected by CVE-2026-103505?
How do I fix CVE-2026-103505?
No fix has been published for CVE-2026-103505 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-103505 being exploited?
There is no known exploitation of CVE-2026-103505 in the wild and no public exploit code.
Sources
Also known as GHSA-9w9f-p9qm-rcm4, GHSA-pv26-6q9q-5773.