# CVE-2026-103508: Path traversal via logging configuration in P4Search

> An authenticated administrator can exploit path traversal in logging configuration to write or delete files, potentially leading to code execution.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-m6jx-f652-pc27

## What is CVE-2026-103508?

CVE-2026-103508 is a high-severity path traversal vulnerability in Perforce P4 (Helix core), published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

P4 Search (formerly Helix Search) allows an authenticated user holding administrative privileges on the connected P4 Server to supply a crafted logging configuration that causes files to be written or deleted outside the intended logging directory. This could lead to code execution as the P4 Search service account. This issue affects P4 Search 2026.4.2 and earlier.

Perforce resolved it in 2026.4.3.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-103508?


## How do I fix CVE-2026-103508?

No fix has been published for CVE-2026-103508 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103508 being exploited?

There is no known exploitation of CVE-2026-103508 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103508 and fix it if it is affected.

What it is: CVE-2026-103508 is a high-severity path traversal vulnerability in Perforce P4 (Helix core), published on 15 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103508 in the wild and no public exploit code.

Affected product: Perforce P4 (Helix core). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103508/ (Markdown: https://insights.sbomify.com/CVE-2026-103508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103508
- OSV: https://osv.dev/vulnerability/CVE-2026-103508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103508/
Summaries are generated and may contain mistakes; the official description above is the record.
