# CVE-2026-103513: Memory corruption in Apache DataSketches

> Attackers can trigger memory corruption and potential code execution by providing crafted serialized CPC sketches to applications using the vulnerable C++ library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-2w73-5h25-v3cg

## What is CVE-2026-103513?

CVE-2026-103513 is a critical memory corruption vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds read and write in the CPC sketch deserialization of Apache DataSketches C++ (repo: datasketches-cpp).

A crafted serialized CPC sketch passed to cpc_sketch::deserialize(), from either a byte buffer or a stream, can cause the decompressor to read past the end of the compressed data, because the read position was only checked after decoding finished. In the hybrid flavor, it can also cause a write outside an internal heap buffer, because decoded row indices were not validated. Several other header fields and decoded values, including lg_k, were also not validated. This can corrupt heap memory, causing a crash and potentially enabling further exploitation.

This issue affects Apache DataSketches C++: from 2.0.0-incubating before 5.3.0. Only applications that deserialize CPC sketches from untrusted sources are affected.

Users are recommended to upgrade to version 5.3.0, which fixes this issue.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-103513?


## How do I fix CVE-2026-103513?

No fix has been published for CVE-2026-103513 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103513 being exploited?

There is no known exploitation of CVE-2026-103513 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103513 and fix it if it is affected.

What it is: CVE-2026-103513 is a critical memory corruption vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103513 in the wild and no public exploit code.

Affected product: Apache DataSketches. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103513/ (Markdown: https://insights.sbomify.com/CVE-2026-103513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103513
- OSV: https://osv.dev/vulnerability/CVE-2026-103513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103513/
Summaries are generated and may contain mistakes; the official description above is the record.
