CVE-2026-103515 Incorrect Authorization in GitLab
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-103515?
CVE-2026-103515 is a low-severity vulnerability in Gitlab Gitlab, published on 21 Oct 2026.
Official description
GitLab has remediated an issue in GitLab EE affecting all versions from 19.2 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, when an instance administrator locked a group's Duo availability, an authenticated user with group Owner permissions could have re-enabled AI-backed data egress to a third-party service for that group and its descendant projects, due to insufficient granularity of the admin-lock enforcement controls.
Weakness: CWE-863
Which versions are affected by CVE-2026-103515?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 19.2.0 | 19.3.6, 19.4.3, 19.5.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-103515?
Upgrade gitlab to a fixed version for your release line: 19.3.6, 19.4.3 or 19.5.1.
Is CVE-2026-103515 being exploited?
There is no known exploitation of CVE-2026-103515 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2026-103515, GHSA-x828-vfgm-5mgh.