# CVE-2026-103533: David-Crty databasement database-servers API Endpoint RestoreRequest.php 511 path traversal


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-h4ph-4xq3-682r, GHSA-x225-463f-pgww

## What is CVE-2026-103533?

CVE-2026-103533 is a low-severity vulnerability in David-Crty databasement, published on 1 Oct 2026. 

### Official description

A vulnerability was found in David-Crty databasement up to 1.7.1. This impacts the function https:/github.com/David-Crty/databasement/pull/511 of the file app/Http/Requests/Api/V1/RestoreRequest.php of the component database-servers API Endpoint. The manipulation of the argument schema_name results in path traversal. The attack may be launched remotely. A high complexity level is associated with this attack. The exploitability is said to be difficult. The exploit has been made public and could be used. Upgrading to version 1.7.2 will fix this issue. You should upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-103533?


## How do I fix CVE-2026-103533?

No fix has been published for CVE-2026-103533 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103533 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103533 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103533 and fix it if it is affected.

What it is: CVE-2026-103533 is a low-severity vulnerability in David-Crty databasement, published on 1 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103533 exists.

Affected product: David-Crty databasement. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103533/ (Markdown: https://insights.sbomify.com/CVE-2026-103533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103533
- OSV: https://osv.dev/vulnerability/CVE-2026-103533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103533/
Summaries are generated and may contain mistakes; the official description above is the record.
