CVE-2026-103552 Denial of service in Apache Directory LDAP API

High 7.3 Published Updated

An attacker can cause a stack overflow and denial of service by sending a deeply nested search filter to the server using the vulnerable library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-103552?

CVE-2026-103552 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Stack Overflow vulnerability in Apache Directory LDAP API.

Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.

This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.

Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Weakness: CWE-121

Which versions are affected by CVE-2026-103552?

How do I fix CVE-2026-103552?

No fix has been published for CVE-2026-103552 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-103552 being exploited?

There is no known exploitation of CVE-2026-103552 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-103552, GHSA-mggr-349m-j697, UBUNTU-CVE-2026-103552.

Is CVE-2026-103552 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free