{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-103552 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-103552 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-103552 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-103552 and fix it if it is affected.\n\nWhat it is: CVE-2026-103552 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-103552 in the wild and no public exploit code.\n\nAffected product: Apache Directory LDAP API. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-103552/ (Markdown: https://insights.sbomify.com/CVE-2026-103552/index.md)","id":"CVE-2026-103552","markdown":"https://insights.sbomify.com/CVE-2026-103552/index.md","name":"CVE-2026-103552","record":{"aliases":["DEBIAN-CVE-2026-103552","GHSA-mggr-349m-j697","UBUNTU-CVE-2026-103552"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LDAP API library","requires_auth":"none","summary":"An attacker can cause a stack overflow and denial of service by sending a deeply nested search filter to the server using the vulnerable library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"Stack Overflow vulnerability in Apache Directory LDAP API.\n\nBefore binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.\n\nThis issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.\n\nUsers are recommended to upgrade to version 1.2.9, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Denial of service in Apache Directory LDAP API","id":"CVE-2026-103552","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Windows Partition Management Driver Elevation of Privilege Vulnerability","id":"CVE-2026-103553"},"packages":[],"prev":{"headline":"Incorrect Authorization in GitLab","id":"CVE-2026-103549"},"products":["Apache Directory LDAP API"],"published":"2026-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-02","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a stack overflow and denial of service by sending a deeply nested search filter to the server using the vulnerable library.","url":"https://insights.sbomify.com/CVE-2026-103552/"}