# CVE-2026-103635: Memory corruption in Apache DataSketches

> Crafted Theta sketches cause out-of-bounds reads in Apache DataSketches C++, leading to crashes or memory exposure during deserialization.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-hh2m-8j82-33gp

## What is CVE-2026-103635?

CVE-2026-103635 is a critical memory corruption vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds read in the compact Theta sketch deserialization of Apache DataSketches C++ (repo: datasketches-cpp).

compact_theta_sketch::deserialize() and wrapped_compact_theta_sketch::wrap() read header fields before checking that the input was long enough. For the compressed format, the size check could be defeated by a 32-bit overflow, and two header fields that control decoding were not validated; this also affected deserialization from a stream. A crafted or truncated sketch could cause a read past the end of the input. In the compressed case the over-read can be large, and the bytes read can become part of the deserialized sketch. This can cause a crash (denial of service) and could expose adjacent memory contents.

This issue affects Apache DataSketches C++: from 3.1.0 before 5.3.0. Only applications that deserialize Theta sketches from untrusted sources are affected.

Users are recommended to upgrade to version 5.3.0, which fixes this issue.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-103635?


## How do I fix CVE-2026-103635?

No fix has been published for CVE-2026-103635 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103635 being exploited?

There is no known exploitation of CVE-2026-103635 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103635 and fix it if it is affected.

What it is: CVE-2026-103635 is a critical memory corruption vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103635 in the wild and no public exploit code.

Affected product: Apache DataSketches. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103635/ (Markdown: https://insights.sbomify.com/CVE-2026-103635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103635
- OSV: https://osv.dev/vulnerability/CVE-2026-103635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103635/
Summaries are generated and may contain mistakes; the official description above is the record.
