# CVE-2026-103636: Denial of service in Apache DataSketches

> An out-of-bounds read in VarOpt union deserialization allows attackers to cause crashes or expose memory via truncated input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-9935-w26g-xf2m

## What is CVE-2026-103636?

CVE-2026-103636 is a high-severity denial of service vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds read in the VarOpt union deserialization of Apache DataSketches C++ (repo: datasketches-cpp).

var_opt_union::deserialize() read the 32-byte preamble of a non-empty union after checking that only 8 bytes were available, so a truncated serialized union could cause a read of up to 24 bytes past the end of the input. For such inputs, the size remaining for the embedded sketch was also computed by an unsigned subtraction that could wrap around, so the embedded sketch's own size checks no longer limited reads to the input. The bytes read can become part of the deserialized union's state. This can cause a crash (denial of service) and could expose adjacent memory contents.

This issue affects Apache DataSketches C++: from 2.0.0-incubating before 5.3.0. Only applications that deserialize VarOpt unions from untrusted sources are affected.

Users are recommended to upgrade to version 5.3.0, which fixes this issue.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-103636?


## How do I fix CVE-2026-103636?

No fix has been published for CVE-2026-103636 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103636 being exploited?

There is no known exploitation of CVE-2026-103636 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103636 and fix it if it is affected.

What it is: CVE-2026-103636 is a high-severity denial of service vulnerability in Apache DataSketches, published on 10 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103636 in the wild and no public exploit code.

Affected product: Apache DataSketches. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103636/ (Markdown: https://insights.sbomify.com/CVE-2026-103636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103636
- OSV: https://osv.dev/vulnerability/CVE-2026-103636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103636/
Summaries are generated and may contain mistakes; the official description above is the record.
