CVE-2026-103877 Apache Directory LDAP API: Unsafe loading of Java code from LDAP schema elements

Critical 9.8 Published Updated

A malicious LDAP server can trigger remote code execution in applications using the Apache Directory LDAP API by sending crafted schema data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-103877?

CVE-2026-103877 is a critical unsafe deserialization vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API.

A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. 

This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9.

Users are recommended to upgrade to version 2.1.9, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2026-103877?

How do I fix CVE-2026-103877?

No fix has been published for CVE-2026-103877 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-103877 being exploited?

There is no known exploitation of CVE-2026-103877 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-103877, GHSA-v496-rffp-c5q7, UBUNTU-CVE-2026-103877.

Is CVE-2026-103877 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free