CVE-2026-103880 Apache Directory LDAP API: Denial of service via excessive bcrypt cost factor in stored passwords

High 7.5 Published Updated

An attacker can cause denial of service by storing passwords with excessive bcrypt cost factors, forcing high CPU usage during verification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-103880?

CVE-2026-103880 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API.

Storing a password using the bcrypt algorithm with a high force like 30 in a LDAP server that supports this algorithm will cause the server CPU to  run for hours checking the credentials. A bounded cost should be enforced to avoid a server DOS.

This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9.

Users are recommended to upgrade to version 2.1.9, which fixes the issue.

Weakness: CWE-405

Which versions are affected by CVE-2026-103880?

How do I fix CVE-2026-103880?

No fix has been published for CVE-2026-103880 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-103880 being exploited?

There is no known exploitation of CVE-2026-103880 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-103880, GHSA-q4px-5x5j-5p92, UBUNTU-CVE-2026-103880.

Is CVE-2026-103880 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free