# CVE-2026-103885: Apache Directory LDAP API: Denial of service via crafted telephone number values

> An attacker can cause indefinite CPU consumption in LDAP servers using this library by sending crafted telephone number values.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-103885, GHSA-c2cq-mmh3-7wxh, UBUNTU-CVE-2026-103885

## What is CVE-2026-103885?

CVE-2026-103885 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API.

A LDAP server using the LDAP API (like Apache DS) may consume 100% of a CPU core indefinitely when processing some badly crafted Telephone Numbers.

This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9.

Users are recommended to upgrade to version 2.1.9, which fixes the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-103885?


## How do I fix CVE-2026-103885?

No fix has been published for CVE-2026-103885 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103885 being exploited?

There is no known exploitation of CVE-2026-103885 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103885 and fix it if it is affected.

What it is: CVE-2026-103885 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103885 in the wild and no public exploit code.

Affected product: Apache Directory LDAP API. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103885/ (Markdown: https://insights.sbomify.com/CVE-2026-103885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103885
- OSV: https://osv.dev/vulnerability/CVE-2026-103885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103885/
Summaries are generated and may contain mistakes; the official description above is the record.
