CVE-2026-103923 KaTeX: Existing prototype pollution can bypass trust restrictions
Prototype pollution allows bypassing trust restrictions in KaTeX, enabling XSS via malicious math expressions in applications rendering unsanitized output.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-103923?
CVE-2026-103923 is a low-severity cross-site scripting vulnerability in KaTeX, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. From 0.11.0 until 0.18.2, KaTeX uses ordinary JavaScript property access for the renderer options object, the trust setting, default and processor setting metadata, and namespace lookup and group restoration, allowing inherited properties to be treated as explicitly supplied values. When Object.prototype is already polluted or an attacker controls the options object's prototype, attacker-controlled mathematical expressions can use an inherited trust value to enable trusted rendering and produce links capable of user-interaction cross-site scripting or loading attacker-selected external resources in a consuming application that inserts unsanitized KaTeX output into a page. KaTeX does not itself create the prototype pollution, and rendering an expression alone does not execute script. This issue is fixed in version 0.18.2.
Weakness: CWE-807
Which versions are affected by CVE-2026-103923?
2 open source packages ship an affected version, including katex.
| Package | Affected | Fixed in |
|---|---|---|
katex npm | From 0.11.0 | 0.18.2 |
katex npm | From 0.11.0 | 0.18.2 |
Linux distribution packages (1)
python-jupyterlab-templates openSUSE:Tumbleweed | All versions | 0.5.3-3.1 |
How do I fix CVE-2026-103923?
Upgrade katex to 0.18.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-103923 being exploited?
There is no known exploitation of CVE-2026-103923 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1791284260, CLSA-2026-1792488994, DEBIAN-CVE-2026-103923, GHSA-238p-pmpm-9mq7, MINI-p78h-7q25-wggj, MINI-rhmf-wcw9-4rrr and 2 more.