# CVE-2026-103956: Missing authentication for critical function in Loom for AWS

> Remote attackers can gain super-admin control over the Loom agent control plane if no identity provider is configured, allowing credential theft and policy manipulation.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-vgmj-998f-r8mp

## What is CVE-2026-103956?

CVE-2026-103956 is a critical missing authorization vulnerability in AWS loom, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing authentication for critical function in the authentication dependency in Loom for AWS before 1.6.1 allowed remote actors to obtain super-admin authority over the agent control plane, including registering tool servers, reading stored integration credentials, and rewriting the IAM role policies attached to managed agent roles, via any request to the application API in a deployment where no identity provider is configured.

To remediate this issue, users should upgrade to version 1.6.1 or later.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-103956?


## How do I fix CVE-2026-103956?

No fix has been published for CVE-2026-103956 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103956 exists.

Public exploit code:

- CVE-2026-103956 - Loom for AWS - Critical - Auth bypass - unauthenticated super-admin when no IdP is configured (github_poc): https://github.com/abraxas/cve-2026-103956-loom-unauth
- Loom for AWS < 1.6.1 - Unauthenticated Super-Admin Access (nuclei): http/cves/2026/CVE-2026-103956.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103956 and fix it if it is affected.

What it is: CVE-2026-103956 is a critical missing authorization vulnerability in AWS loom, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-103956 exists.

Affected product: AWS loom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103956/ (Markdown: https://insights.sbomify.com/CVE-2026-103956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103956
- OSV: https://osv.dev/vulnerability/CVE-2026-103956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103956/
Summaries are generated and may contain mistakes; the official description above is the record.
