{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-103958 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-103958 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-103958 is a high-severity server-side request forgery vulnerability in AWS loom, published on 2 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-103958 and fix it if it is affected.\n\nWhat it is: CVE-2026-103958 is a high-severity server-side request forgery vulnerability in AWS loom, published on 2 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-103958 in the wild and no public exploit code.\n\nAffected product: AWS loom. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-103958/ (Markdown: https://insights.sbomify.com/CVE-2026-103958/index.md)","id":"CVE-2026-103958","markdown":"https://insights.sbomify.com/CVE-2026-103958/index.md","name":"CVE-2026-103958","record":{"aliases":["GHSA-w6g6-h8pv-6mc7"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS Loom","requires_auth":"high_privilege","summary":"An authenticated attacker can exploit SSRF in AWS Loom to steal container role credentials and read internal network responses.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS before 1.7.0 might allow an authenticated remote user to obtain the credentials of the application's own container role and to read responses from arbitrary internal network locations, via a crafted connection address supplied when registering, updating or testing a tool server or remote agent.\n\nTo remediate this issue, users should upgrade to version 1.7.0 or later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS","id":"CVE-2026-103958","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Information disclosure in Download Manager","id":"CVE-2026-103964"},"packages":[],"prev":{"headline":"Server-side request forgery in the OAuth2 discovery handling in Loom for AWS","id":"CVE-2026-103957"},"products":["loom"],"published":"2026-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-09","vendors":["AWS"]},"summary":"An authenticated attacker can exploit SSRF in AWS Loom to steal container role credentials and read internal network responses.","url":"https://insights.sbomify.com/CVE-2026-103958/"}