# CVE-2026-103958: Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS

> An authenticated attacker can exploit SSRF in AWS Loom to steal container role credentials and read internal network responses.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-w6g6-h8pv-6mc7

## What is CVE-2026-103958?

CVE-2026-103958 is a high-severity server-side request forgery vulnerability in AWS loom, published on 2 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS before 1.7.0 might allow an authenticated remote user to obtain the credentials of the application's own container role and to read responses from arbitrary internal network locations, via a crafted connection address supplied when registering, updating or testing a tool server or remote agent.

To remediate this issue, users should upgrade to version 1.7.0 or later.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-103958?


## How do I fix CVE-2026-103958?

No fix has been published for CVE-2026-103958 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-103958 being exploited?

There is no known exploitation of CVE-2026-103958 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-103958 and fix it if it is affected.

What it is: CVE-2026-103958 is a high-severity server-side request forgery vulnerability in AWS loom, published on 2 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-103958 in the wild and no public exploit code.

Affected product: AWS loom. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-103958/ (Markdown: https://insights.sbomify.com/CVE-2026-103958/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-103958
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-103958
- OSV: https://osv.dev/vulnerability/CVE-2026-103958

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-103958/
Summaries are generated and may contain mistakes; the official description above is the record.
