# CVE-2026-104020: Uncontrolled recursion in the Ion reader in Amazon Ion Python

> A remote attacker can crash applications using the Amazon Ion Python library by sending deeply nested Ion values, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-93q6-f8hx-vv7f

## What is CVE-2026-104020?

CVE-2026-104020 is a high-severity denial of service vulnerability in Amazon ion-python, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled recursion in the Ion reader in Amazon Ion Python before 0.15.0 might allow a remote unauthenticated actor to crash the application using the library, resulting in a denial of service, via a crafted, deeply nested Ion value.

To remediate this issue, users should upgrade to version 0.15.0 or later.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-104020?


## How do I fix CVE-2026-104020?

No fix has been published for CVE-2026-104020 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-104020 being exploited?

There is no known exploitation of CVE-2026-104020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104020 and fix it if it is affected.

What it is: CVE-2026-104020 is a high-severity denial of service vulnerability in Amazon ion-python, published on 1 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104020 in the wild and no public exploit code.

Affected product: Amazon ion-python. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104020/ (Markdown: https://insights.sbomify.com/CVE-2026-104020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104020
- OSV: https://osv.dev/vulnerability/CVE-2026-104020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104020/
Summaries are generated and may contain mistakes; the official description above is the record.
