# CVE-2026-104102: copyparty FTP: upload outside defined volumes (limited path traversal)

> Authenticated users can upload files outside configured volumes via FTP path traversal, potentially affecting other host software.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-phv8-wgjp-g4p9

## What is CVE-2026-104102?

CVE-2026-104102 is a medium-severity path traversal vulnerability in 9001 copyparty, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

copyparty is a portable file server. Prior to 1.20.19, FTP upload path handling does not confine destinations to configured copyparty volumes. When FTP or FTPS is explicitly enabled, a low-privileged authenticated user can submit traversal paths during upload to create a new file outside configured volumes wherever the copyparty process has write permission. The attacker cannot read or overwrite files, the output name receives a randomized suffix, and copyparty does not execute the file; however, unrelated software on the same host could process the newly created file. This issue is fixed in version 1.20.19.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-104102?

2 open source packages ship an affected version, including copyparty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.20.19 |
| `copyparty` | PyPI | All versions | 1.20.19 |

## How do I fix CVE-2026-104102?

Upgrade copyparty to 1.20.19 or later.

## Is CVE-2026-104102 being exploited?

There is no known exploitation of CVE-2026-104102 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-104102 and fix it if it is affected.

What it is: CVE-2026-104102 is a medium-severity path traversal vulnerability in 9001 copyparty, published on 12 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-104102 in the wild and no public exploit code.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.20.19
- copyparty (PyPI): affected all versions; fixed in 1.20.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-104102/ (Markdown: https://insights.sbomify.com/CVE-2026-104102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-104102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-104102
- OSV: https://osv.dev/vulnerability/CVE-2026-104102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-104102/
Summaries are generated and may contain mistakes; the official description above is the record.
