{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-104126 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-104126 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-104126 is a medium-severity code injection vulnerability in jumpserver, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-104126 and fix it if it is affected.\n\nWhat it is: CVE-2026-104126 is a medium-severity code injection vulnerability in jumpserver, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-104126 in the wild and no public exploit code.\n\nAffected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-104126/ (Markdown: https://insights.sbomify.com/CVE-2026-104126/index.md)","id":"CVE-2026-104126","markdown":"https://insights.sbomify.com/CVE-2026-104126/index.md","name":"CVE-2026-104126","record":{"aliases":["GHSA-gr5x-5c4h-867g"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JumpServer bastion host","requires_auth":"high_privilege","summary":"Authenticated users can inject malicious Ansible template expressions to disclose sensitive files or execute limited commands within the automation process.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to 4.10.17-lts, JumpServer's Ansible-based automation rendering can evaluate attacker-controlled template expressions from users who have permission to create or execute affected automation tasks. Crafted content can invoke sensitive Ansible lookup behavior, including file, pipe, env, and password lookups, within the Ansible execution context, which can disclose files or environment values and may permit limited command execution under the privileges of the automation process. The issue does not provide unauthenticated access or direct access to unrelated JumpServer assets. This issue is fixed in version 4.10.17-lts.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"JumpServer: Ansible Automation Template Rendering Allows Unsafe Lookup Plugin Invocation","id":"CVE-2026-104126","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"QGIS: Stored XSS in WFS3 getFeatures HTML page via unescaped feature attribute values","id":"CVE-2026-104140"},"packages":[],"prev":{"headline":"SourceCodester Online Reviewer Management System btn_functions.php activity sql injection","id":"CVE-2026-104123"},"products":["jumpserver"],"published":"2026-10-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["jumpserver"]},"summary":"Authenticated users can inject malicious Ansible template expressions to disclose sensitive files or execute limited commands within the automation process.","url":"https://insights.sbomify.com/CVE-2026-104126/"}